USB Dmx Adapter RS485 fix

DMX RS485 Wrong Board Fix

This is a fix for my other tutorial : ” DIY USB DMX INTERFACE FOR UNDER $10“, apparently there are multiple versions of this board being sold. Depending on what site you bought it you may or may not have received a working chip. For those who are stuck with a non-working chip, this is a guide on how to modify yours to allow DMX data output. Solution found by GermAndy!

– non-working RS485 USB Board
– Soldering Iron, Tin
– Steady hand

The Problem
There are different models of the USB RS485 interface being produced. Some of these models will not work out of the box and need some small modifications to  work. I have not yet found a way to identify these boards but here is a fix thanks to GermAndy.


The problem seems to be with the 75176 chip:


The problem is with the DE pin… because the DMX data is a bit different from the original RS485 protocol. the DE pin does not raise because the RS485 protocol is not properly ended. This means there is no data send out as long as the protocol has not ended it’s stream correctly.

Solution 1

Lifting the DE / RE pin from the board. Lifting the DE/RE pins from the board will allow the 75176 chip to put out DMX data without waiting for a verification of the protocol. In most cases this solution should work. If for some reasons this did not work try solution 2.

Some boards still don’t work after lifting the DE/RE pins, Solution 2 fixes these boards:

Solution 2

If solution 1 did not work, you have to connect the DE/RE pin to the +5V of the 75176 chip. Since the chip is very small it’s recommended to use a soldering iron with a small tip. the +5v is the VCC pin on the chip diagram :


Image by Germandy

Fix For Mac(by David P.)

So basically here are the steps for future readers:

On MacOS X (El Capitan)

Everything should be fine. If not, also follow instructions on


Comments have been disabled, Discussions on this post continue in this Forum



42 Responses

  1. For me, only the 2nd solution works.
    The chip mounted on the board (ordered to DX) is: T485EEN.

    May be, the universal solution is to replace the chip with this: MAX481ECSA+ ( Farnell, 9725130 3,53 € )

    1. Thanks for your reply, the universal solution will probably be replacing the chip but most people can’t change a chip themselves, so i wrote this bypass which is a lot easier and can be done by anyone with some soldering experience.

  2. hi I’m from belgium. I have the save interface and it don’t work. I don’t have good english . Can you explain me what is exactly “lifting the DE/RE pins from the board” how to do that.

    1. Lifting the DE/RE pins means that you disconnect the chip’s DE and RE pins from the board. this can be done by desoldering the pins or just cutting the pins.
      If you cannot get this board to work, there is another guide that requires no fix :

      Dutch : je kan je dmx controller laten werken door de DE en RE pin van de printplaat los te maken zodat deze geen verbinding meer maken. dit kan je doen door deze pins te desolderen of door de pins door te knippen. op de bovenstaande link kan je ook een guide vinden waarvoor geen fix nodig is.

      1. SP485EE Chips are designed/manufactured by Sipex Corporation, only chips designed by FTDI will work so you will need the FT232RL chip by FTDI. However i’ve not tested other brands throughly so you can give your chip a try.

        1. yes but i’ve the ftdi chip, I was referring to the “chip” (excuse for ignorance) in the image at the top of this page.

          1. The chip in the picture at the top of the page is the 75176B. It is the level shifter which transform the low level signal from FTDI chip to RS485 levels, used by DMX protocol. It is a kind of signal amplifier. Your SP485EE has the same functionality than 75176.

        2. Ok thank you from “arci on the road” from Castellaneta, Italy!!! We solved with second solution, thank you again 🙂

  3. Lifting pins 2 and 3 worked for me. No luck with FT_prog. Production date 2013/06/4 as mentioned by others with this issue.

    Additionally, in OSX, I needed to unload FTDIUSBSerialDriver.kext, not sure when or for what I installed it but it interferes with the ftd2xx drivers.

    Thanks for the great post Steven and solution GermAndy!

    1. cause your ic is clone and the new ic has eeprom bloqued. its because the ftdi campany has make a drvier that erase the chip clone. so, the chinesse have bloqued it.

        1. Thing is I’ve found out that it is probs true. Links are inthis thread. Fake chips are blocked. I bought 1pc from the first supplier you recommend and that was fake alas blocked. Ordered from the other supplier and they 3 pcs I bought work just fine.

            1. That is quite impossible nowadays, there are soo many different producers/models/revisions there is no clear way to determine what chips work before buying. you just have to cross your fingers they send a working one but you probably will have to apply a fix.

  4. I use the very chip described at the begining and it work pretty well out of the box. BUT! After working perfectly 2 to 3 minutes, sometimes a little more,it will stops sending. The software and the computer itself say that the hardware it’s still connected but it won’t send. As soon as I unplug and plug back the USB from the computer or the “unit” it picks up again and works for another little while. Does anyone have any idea that can help me out?

  5. I tried a different pc and still did the same thing; work for a little while and then freezes. Any suggestions, maybe some setting that I might be able to load with tge FT_Prog. Like I said, all I’ve done is installed the driver and it worked, but it has that problem. Any suggestions on anything that I can try. I really appreciate this.

    1. did you figure it out? i’ve got two modules with exactly the same problem.I have no dmx terminator lying around, but the module will stop after a while for 10 seconds and then proceed again, even without any lamp connected. If it stops, the rx led is not blinking. Once it resumes, the lights comes up again.

      Weird thing is that the 3d visualiser also stops working (it did however work without any interruption when i was only ‘dry testing’ with a virtual adapter

      1. hmm, you could try other software, also try plugging your usb dmx adapters in a powered usb hub. Its the first time I hear it proceed again after it stopped.

  6. For solution 2 do you first have to lift the DE pin and then connect it to +5V or do you have to leave the DE pin connected to the board and then link it to the +5V pin ?

  7. What is the proper replacement chip for this, which requires no modification? I bent the leads up, but one of the leads broke. So I can’t try Solution #2. Now I must replace the chip anyway.

    Since I’ve already come this far, I’d rather repair this board than to start a new project.

    1. if you find any fake FTDI chip produced before 2015 you should be good, the problem is there is no way to tell what chip will work or not. I’m sorry, it seems the RS485 with RJ45 plug still works out of the box but you must make sure you have the RS485 variant and not the usb network adapter.

  8. Hey Steven,

    Im having a bit of a problem trying to get this working. Ive done all the steps but my light just flashes when i plugin the usb cable to the computer.

  9. Hi Steven
    I tried many other ways to solve my problem and this only worked !! And not needed another source of feeding only the weld. I paid $ 3 in alli express and rode my dmx dongle I am very happy , thank you for your help Thank Brazil .

  10. Hi Steven. i bought a new one usb to rs485 ….. but my fix does not work ( because it was already shorted) ( point of that is that chip can not reset it self… ( it should be only two shorted pins as i understood)

    now testing De/Do of level translator ( wich i gues it is) shorting to +5V…. and i recomend shorting it to main rail ( it is easyer to solder…. will provide another feedback)

  11. hey. i have lifted the two pins and the adaptor works for about a minute and then crashes. I have tested in 3 computers and the resoults are the same. Should I sort it to the 5v now or I have another problem?

  12. I tested a new batch of adaptors with QLC+.

    Not working out of the box with windows 10 and default driver. Re-programing the chip failed, chip locked.

    Only solution 2 seems to be working… Seems to be unstable, has disconnected after a while.

    Re-booted on Linux: I tried Ubuntu 16.04: Adaptor works out of the box. Stable

    Booted on the Raspberry Pi 3 with Raspbian Jessie: Adaptor works out of the box. Stable

    I would say that the problem seems more related to the windows driver than to the interface itself.

    Or that default linux driver is so ‘elementary’ that it works without any problem…

    Choose your camp…;-)

On Key

Related Posts